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Introduction 

This Guide is designed to assist you in the presentation of the UniOP Designer for Windows software 
program. It is a step by step instruction process that helps to get all the information across to the 
prospective customer while demonstrating the Designer for Windows program. 
This is just a guide for assistance, it is not written in stone, as we all know that variations in the actual 
presentation depend on the customer and application.  For a more detailed description of a particular 
subject in this document, please refer to the Designer for Windows software manual or to the Tech 
Notes. 
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Initial Presentation of the Designer for Windows 

The first thing to do when showing the product is get a feel for the application. The display size, PLC 
type and model all contribute to the actual presentation. It is advisable to have all the cables needed for 
the particular PLC and communication type you are using, ready or on hand for the demo. It is also 
good to have a PC color monitor with you or on hand to show the software to customers, as it provides 
for an overall better presentation. 

Getting Started 

1. Start the Designer for Windows. 
2. The UniOP panel should be connected to the PC with a CA1 or CA2 cable. 
3. Make sure the cable is connected to the correct available PC port, so you can download a 
 project to the panel or get panel resources. 
4. Make sure the panel is in Configuration mode. 
5. Select Get Panel Resources from the Transfers pull down menu. 
6. Say Yes, to copy panel resources. This transfers the panel size automatically from the 
 panel’s serial EPROM, and updates the Designer display and PLC driver information. 
7. Now you are ready to start developing and demonstrating the UniOP Designer functions. 

Creating a Project 

1. The first thing to do is to select Change PLC Driver from the Project menu.  Choose the 
 correct driver for the PLC that you are using and then choose OK. 
2. Select Panel Setup from the Project menu and choose the correct panel type and  settings. 
3. Select PLC Setup from the Project menu and choose the proper PLC model. Set baud rate 
 for PLC communication by selecting PLC COMM.  The baud rate, parity, and stop bits 
 should be set to the same as what the PLC communication port is set at in the PLC 
 software or switches if applicable.  Exit the panel setup by selecting OK, after all 
 parameters are set up correctly. 
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4. Select RDA Setup from the Project menu.  This dialog box is used to change the default 
 addresses of the RDA or Reserve Data Area.  The RDA is a block of memory that 
the  panel reserves for communication and data handling between the PLC and the panel. 
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Demonstrating the Functions of the Designer 

Numeric Fields 

1.  One of the first things to demonstrate is the define field for a PLC variable. This dialog  box 
can pop up by default just by double clicking the left mouse button or single clicking  the right 
mouse button on the page where the field will begin, or by clicking and  dragging the mouse to 
achieve the proper field dimensions and then select the numeric  PLC field icon on the top of the 
Designer menu.  The latter method will automatically set  the field dimensions. 
 

 
 
2. The PLC Reference section, in the upper portion of the screen, is dependent on the type  of 
PLC selected.  The fields in this section refer to a specific PLC type.  They control the  type, 
format, and address of the data. 
3. The lower portion of the Define Field screen is not PLC specific.  The fields in this area  are 
used to inform the display how to handle the data.  You can define the following: 
    ?  What form the data will be displayed in. 
    ?  Whether to use decimal or hex. 
    ?  Whether the data is read only or read/write. 
    ?  The size of the data field. 
    ?  Whether the data will be scaled and if so, to what extent.  See Tech Note # 18 for  
        more detail on scaling. 
    ?  Minimum and maximum values if the data is read/write. 



  Tech-note 
PN#  Tn040-3.doc - 2001-01-31 - Ver. 1.00 

Page 5 

Bargraphs 

1. The first thing to do is click and drag the mouse on the display representation to select the 
 size and location of the bargraph.  Then click the bargraph icon at the top of the page in  the 
Designer menu. The Bargraph define field will automatically appear and will show a  default 
address to dynamically fix the bargraph to.  Change the default address to an  address you would 
like the bargraph to be dynamically referenced to. 
2. This is the same type of Define Field screen that appeared for the numeric field.  The 
 PLC Reference section is used as before. 
3. The Display Format field will show vertical or horizontal, depending on the appearance  of 
the rectangle you created.  The appearance can be changed by selecting Horizontal or  Vertical and 
then entering specific height and width in the Field Dimensions. 
4. The max. value for this field is the max. range for the bargraph. For example, if 300 is the 
 max. value, when the PLC word value reaches 300 the bargraph will be full. 
 

 
 
 

NOTE: You can put a box around anything by clicking and dragging the mouse and 
highlighting an area.  Then select the menu at the top of the page, Edit/ Rectangles & 
Symbols.  Then select the box style.  It will appear surrounding the area you just 
highlighted. 
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Message Fields 

1. To create a message field you should click and drag the mouse pointer as before, the 
 Designer will automatically limit your selected height to one line.  Drag the mouse to 
 create the width of the field area on your display.  This width is equivalent to the number  of 
maximum characters the message field can contain.  Then click on the message icon at  the top of 
the Designer screen.  The message define fie ld will appear. 
2. Enter the parameters you prefer for this message field.  For example if you dynamically  fix 
the message to a bit, the field will have only 2 messages, one for the value of 0 and  the other for 
the value of 1.  If you select a word the field will have a maximum of 256  messages, one 
message for each value of the word from 0 to 255.   The min. and max.  values set the number of 
possible messages. 
 

 
 
3. You then click the edit message button to enter your message for the different data 
 values. 
4. Select which message to edit by clicking the left mouse button on the correct number and  then 
type the desired message. 
5. It is also possible to add special characters to your message from your font.  Just click on  the 
special characters button in the edit message field and either select the highlighted  character or 
double click on the character to select it.  Press OK and the characters will  appear in the 
message data value position you were last in before entering special  characters mode. 
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Attributes 

1. To use the attribute function of the display, you must click and drag over the entire field  that 
you wish to highlight, reverse, blink, or any combination.  
2. Click on the Attribute icon and the attribute define field will appear. 
3. You can select either dynamic or static field representation. If you select static, the field  will 
allow you to setup the attribute by selecting one or all of the screen attributes. 
 

 
 
4. If you select dynamic, the screen attribute will be fixed to a value of a word or bit in the 
 PLC. Enter the dynamic address in the same format as you had done previously for the 
 other define fields. 
 
 NOTE: The attribute characteristic will depend on the value of the first 3 bits of the word  you 
have it referenced to.  
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Keyboard Macro Editor 

The Macro Editor has many possible functions. This powerful tool can enable the Designer to 
download Keyboard Macro functions to the UniOP as part of the project. This could also be 
considered local processing.  Many routines that are written in ladder logic can be written using the 
Macro Editor.  Not only does this save time in programming, but the response time of the routines will 
be much faster since the functions will be performed internally in the panel. 
 

 
 
At the top of the Macro Editor dialog box is the list of the panel keys that are available for 
programming.  You select the key by clicking the left mouse button over it.  The selected key is 
displayed in the lighter shade of the color than the rest of the keys.  There are more keys available for 
programming than could be displayed.  The scroll button control, to the left of the keys, may be used to 
scroll through the list of keys.  The list of tab controls shows available panel operating modes (System, 
All Pages, etc.).  The selected operating mode is indicated by the tab displayed in the foreground with 
respect to the other tabs.  The small circle at the top left side of each tab can be yellow or red, light 
and dark on monochrome monitors.  Yellow indicates that no macro is defined for any key in the 
operating mode represented by the tab.  Red indicates that at least one key is programmed.  Below the 
list of tabs is the toolbar with the buttons representing elementary macros.  The list box at the bottom 
left side of the dialog box displays all the elementary macros that make up the complex macro under 
construction.  This list box is also used to preview the content of the macros that are already defined.  
You can insert, append and delete the elementary macros in the list box by clicking the buttons on the 
right side of the list.  Since this is an elaborate capability of the unit, Tech Note #28 was written to 
describe the Macros in greater detail. The Macro Editor Help file can also be selected from the Macro 
Editor window for on-line help. 
 
Note: The Macro Editor can only be selected from software versions 3.05 or greater.  Also the 
Macros can only be downloaded to a panel with firmware version 3.12 or greater. 
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Passwords 

1. The UniOP has 8 levels of passwords so that different operators and supervisors can be 
 enabled to do different things within the project of the UniOP. 
 

 
 
2. The highest level can always do all things so as not to lock this person out of 
 Configuration Mode. This is in case the highest level person would like to update the 
 project or change the project of the UniOP. 
3. All UniOp panels provide password protection for the following: 
  CONF - Access to Configuration Mode. 
  TIME - Access to the Time and Date mode. 
  PAGE - Access to Direct Page Selection mode. 
  ACK - The right to acknowledge alarms. 
  PRINT - The right to request printouts. 
  ALOGI - Automatic Login 
  ALOGO - Automatic Logoff 
  Data entry enable - Access to Data Entry mode for specific pages. 
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Alarms 

Compatibility Mode 

 
The UniOP offers the storage and automatic display of up to 256 alarm messages.  Priority levels (0 - 
255) can be assigned to handle simultaneous alarms.  Alarms are each assigned an individual bit in the 
Alarm Update Area of the RDA.  Alarms are triggered by a high bit from the PLC. 
  
1. Select Project / Alarms from the top of the Designer pull down menus. 
2. Click on Compatibility Mode and then on OK. 
3. The Compatibility Alarm define field will appear. 
 

 
 
4. Type in your alarm message for the respective alarm bit which is mapped in the Reserved 
 Data Area for communication with the PLC. 
 

  bit  

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 

bit 

0 

 
ALARM  

UPDATE AREA 21 A16 A15 A14 A13 A12 A11 A10 A9 A8 A7 A6 A5 A4 A3 A2 A1 

 22 A32 A31 A30 A29 A28 A27 A26 A25 A24 A23 A22 A21 A20 A19 A18 A17 
  ---------- (break) --------- 
 35 A240 A239  A238  A237 A236 A235 A234 A233 A232 A231 A230  A229 A228 A227 A226 A225 

 36 A256 A255 A254 A253 A252 A251 A250 A249 A248 A247 A246 A245 A244 A243 A242 A241 

 
5. You can then select which alarm data you want to go to the circular buffer Event List in  the 
UniOP, or be printed from the UniOP automatically if a printer is attached to the unit  while on-
line and the alarm occurs. These choices are selected as Time of ACK, Time of  Alarm (ON), or 
Time of reset (OFF). The buffer holds 256 different events at one time  the newest knocks out the 
oldest, which is why it is called circular. 
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6. You can also select if you want the alarm to have to be acknowledged by the Operator.  This 
is selected by clicking the Operator ACK required button and putting an X in this  box. 
7. When this is selected and an alarm occurs the alarm page appears on the display and the 
 ACK letters will be flashing and the alarm light on the UniOP will also be flashing. To 
 acknowledge the alarm, you must press enter for a few seconds until the ACK letters 
 disappear from the display. 
8. Then press clear and the display will return to page mode of your project. 
9. If the alarm bit is not reset the alarm page will keep reappearing until the alarm bit is 
 reset, and the alarm light on the front panel of the UniOP will be on but not flashing 
 unless there is several alarms and at least one needs acknowledgment. 
10. The time and date of the alarm will be automatically displayed on the screen along with  the 
alarm message. 

Alarm Options 

1. The alarm page's appearance can be prevented, by setting the RDA control bit C2.  This  bit 
prevents the alarm page from appearing on the display. So if that particular Alarm has  Operator 
Acknowledgment Required X'd, the  operator would have to go into the main  menu to ACK the 
alarm by pressing the ENTER key for about 2 seconds and selecting  alarms. Then press enter to 
ACK the alarm. The ACK letters will disappear and the alarm  light will stop flashing but will still be 
on if the alarm bit is still set. 

Enhanced Mode 

The enhanced mode offers more flexibility and a greater number of alarms.  This mode offers up to 
1024 alarms which are broken into 4 blocks of 256.  Each block can be addressed to any register and 
is not restricted to a pre-defined register as with the Compatibility Mode alarms.   
 
1. Select Projects / Alarms from the top of the pull down menus. 
2. Click on Enhanced Mode and then on OK. 
3. The Enhanced Alarms define field will appear. 
4. The Block # field allows you to select between the four alarm blocks. 
5. The # of Alarms field is used to specify how many alarms will be used in that block.  The 
 Designer will automatically round off the specified number to a multiple of 16 since the 
 alarms are word addressed. 
6. The Update cycle  field is used to change how often the alarms are updated.  The Popup  
 button allows the user to specify when, or if, the default alarm screen appears when an  
 alarm occurs. 
7. The Block start address field is used to specify the starting address of the current block. 
8. If you are unsure how to address the alarm block, click on Address Reference.  This will  give 
a detailed dialog box for addressing.  If this panel is used in a network, you will  have to use this 
Address Reference to specify node numbers. 
9. You can scroll through the alarm messages by using the scroll arrows to the right.  To 
 create or edit a message, simply highlight the desired message and type your text. 
10. If you do not type a text message into each of the specified alarms within a block, then  the 
Designer will automatically delete any unused alarms above the last alarm with text  entered.  
That is to say that if you specified there were to be 20 alarms within a block  and you entered text 
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messages for the first 14 alarms, then the Designer would  automatically reduce the number of 
alarms in that block down to 16.  This would be 16  instead of 14 because the alarms are 
addressed as individual bits within 16-bit words. 
11. The Alarm # field can also be used to select a specific alarm. 
12. The On alarm go to page field can be used to have the program jump to a specified page 
 when that alarm is activated.  This also requires that you set up a keyboard macro so that 
 if multiple alarms occur at once, the program is not jumping from page to page.  The 
 keyboard macro should be set up so that the program will go to a specified page only 
 when a specific key is depressed.  The default setting for this field is 0.  When this field is 
 0, the program cannot jump to any page because there is no page 0.  
 

 
 
13. You can select whether the alarm requires acknowledgment. 
14. You can select which alarm data you want to go to the Event list or to be printed by 
 placing X’s in the appropriate boxes.  You can select between Print alarm ON, Print 
 alarm OFF, and Print time of acknowledgment. 
15. The Enhanced Alarm mode also adds the Delete, Copy, and Paste features for use in 
 editing the alarm messages.  This makes editing the text easier if you have many  messages 
which are similar.  It also allows you to create alarm messages in a text editor  such as 
 Windows’ Notepad.  You can then copy the messages into the clipboard and then 
 paste them into the alarm message dialog box. 
16. Please refer to Tech Note # 38 for more detail on Enhanced Alarms.   
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PLC to PLC Data Transfer 

This is a technique of exchanging data between two or more PLC’s or between registers within a 
single PLC.  The PLC’s can be connected either locally over multi-drop network to a single UniOP in 
non-networked project or both locally and/or remotely to different UniOP nodes in a networked 
project.  That is to say that the PLC’s can be connected by their own network or the PLC’s can be 
networked by using the UniNet Network.    
 
We’ll call one complete PLC to PLC data transfer a “Job”.  To set up a transfer, select PLC to PLC 
Data Transfer item from the Project menu.  The dialog box shown below will be displayed. 
 

 
 
The first field is used to select between the different jobs.  Click on the Source Reference button to 
specify the register to be read.  The dialog box shown below will then be displayed. 
 

 
 
These fields will be slightly different depending on the PLC that you are using.  Use these fields to 
specify the type of data, format, and address of  the register that you wish to read.  Enter the number 
of words to be transferred in the appropriate box.  Click on the destination button, and you again see 
the dialog box as shown above in Figure 3.  Enter the correct information for the register where you 
want the data written. 
 
If the Job Execution Mode is set to In Cycles, the panel will automatically transfer the data on each 
cycle.  The cycle period can be set from 10 ms to 127 sec.  Remember the faster the cycles, the 
faster the panel will transfer data, but this will slow down the rest of the system.  If the Job 
Execution Mode is set to On request, the PLC must send a  request to the Interlock Mailbox before 
the data will be transferred.  Then next section will describe the PLC Interlock Mailbox. 
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PLC Interlock Mailbox 

The UniOP Interlock Mailbox is a new facility designed to make it easier for the operator panel to 
interact with the PLC ladder program.   The Mailbox is simply a group of registers in the PLC 
memory (from a minimum of 2 registers to a maximum of 20).  The Mailbox can be freely placed in 
the PLC memory at an address selected by the user.  When the Mailbox is enabled, the operator panel 
cyclically reads the contents of the Mailbox from the PLC.  The PLC can command the operator 
panel to perform certain tasks by placing data in the memory area used by the Mailbox.  When the 
panel detects that the PLC has written data in the Mailbox, it interprets the data as a numeric code for 
a required command.  If the panel recognizes the command it immediately executes it.  If the 
command requires some response from the panel then the panel places the response back in the 
Mailbox itself.  
 
To enable the Mailbox, choose the PLC Interlock Mailbox item from the Project Menu.  The dialog 
box shown below will then be displayed.  
 

 
 
By default the Mailbox is disabled, simply click on the first box to enable it.  The two radio buttons 
allow you to enable the Mailbox in either of the two different modes: 
  ? Cyclical read 
 ? Cyclical read enabled by a bit in the PLC Control Word (PCW) 
 
In the latter case, the panel will cyclically read the data in the Mailbox only when bit C7 in the PLC 
Control Word of the Reserved Data Area is set.  The purpose of this mode is to reduce the 
communication time when there is no need for the PLC to send commands to the panel. 
 
The Read Cycle time specifies how frequently the operator panel will read the data in the Mailbox to 
check if  it contains a new command.  The faster the Mailbox Read cycle , the faster the panel will 
respond to commands from the PLC, but of course, the update of the variables shown on the display 
will be slower.   
 
The Interlock reference is the address of the first Mailbox register in the PLC memory.  The address 
can be entered directly as a string or with a fill-in-the-blank dialog box displayed by clicking on the 
Reference button.  When entering the PLC address, care must be taken to ensure that the PLC 
memory used by the Mailbox does not overlap with the memory areas reserved for other panel 
functions such as panel status, alarms, I/O update, keyboard update, etc. 
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Font Editor 

 
1. The Font Editor allows you to modify the down-loadable font of semi-graphical displays.  
2. Select Font Editor from the Options pull down menu. 
3. Your font will appear on the display in the font editor. 
 

 
 
4. You can select one character to change or you can select several characters as a symbol.  
5. To select symbol mode, you select Options / Define Symbol from the pull down menu. 
6. Select Symbol Dimensions and enter the height and width of the symbol you would like to 
 define. Select OK. 
7. Select Options / Define Symbol again and then select Draw New Symbol. 
8. The display will change to the Symbol dimensions you selected. It will put all the  symbols 
from the font, where the cursor is at, in this symbol edit box. 
9. You can now edit this symbol and even give it a name for later use from the Edit / Draw 
 Object selection in the Designer. 
10. To give it a name you must select Options / Define Symbol / Symbol Name from the 
 Font Editor menus. Then just give this symbol or group of selected characters any name. 
11. When finished modifying the font, you must save the font by selecting Save or Save As 
 under the File menu. 
12. The font must then be installed by selecting Install/View installed Fonts under the File 
 menu.  Select which display panels you want to use this font with and click on Install 
 Font. 
13. The Font Editor has an extensive help file to aid you in the event you have more  questions. 
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 Recipes 

All versions of the UniOP panels with firmware 4.00 or greater, offer the use of recipes. Recipes 
provide a powerful way to extend the capabilities of a PLC.  A recipe allows data to be stored for use 
by an attached PLC.  The data can be written to the PLC, when required, or can be read from the 
PLC and then placed into the recipe memory.   
 
A Recipe is associated with a particular page and is composed of all the Recipe data items on that 
page.  However, there can be many different parameter sets.  This allows the programmer to enter 
many different sets of parameters for the PLC.  For example, one set may be used to configure the 
PLC to control the production of 2mm screws and another set for 5mm screws.  Several more 
parameter sets could be added to control production of other sizes.  This allows the operator to easily 
change what size screw a machine will produce by simply selecting a different parameter set.   
  
Recipes are created by clicking on the Recipe icon.  Then the data fields are create on the screen the 
same as for normal PLC data, except that the screen will be titled Define Field - Recipe Item.  After 
all the Recipe items are defined, you can go to the Configure Recipe screen under the Page menu to 
enter the values for the different parameter sets.  When you finish creating a recipe, the Data Field 
Source will stay in the PLC Recipe Data mode until it is changed.  This means that if you want to 
enter regular PLC Data that you must click on the PLC Data icon before creating the new field. 
 

 
 
For a more detailed description of recipes, please refer to Tech Note #32. 
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UniNET Network 

The UniNET Network makes it possible to connect 2 or more panels (maximum 32) with a RS-485 
connection.  This makes it possible for one panel to display either data from the PLC attached directly 
to it, or from PLC’s attached to other panels on the network.   
 
The operator panels attached to the UniNET Network can be classified in two categories depending 
on the type of communication that they can support once they are placed in the network. A panel is 
considered a Server when it is connected directly to a PLC.  A Server makes data in its PLC available 
to other panels.  A panel is considered a Client when it request data from a PLC attached to a Server 
on the network.  This means that in certain cases, a panel can be both a Server and a Client.  This 
means that there are three types of networks.   
  
  ?  Single server, multiple clients   
  ?  Multiple servers, multiple clients, same PLC types   
  ?  Multiple servers, multiple clients, different PLC types   
 
You must first configure the panels for a network.  This is done by selecting Options / Configure 
Network.  You can select between the three basic types of networks shown below. 
 

 
 
 
 
In the first two cases the Designer program will ask you to enter the number of Clients and Servers 
and then automatically configure the network to default values.  If you wish to make changes to the 
default settings of the network, select Options / Configure Network again and a different screen 
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(shown below) will appear this time that will allow you to make changes.  The third case is the most 
advance option and gives the user complete control over the network.  This allows the user to make 
full use of the capabilities of the UniNET network, but this is at the expense of having to explicitly 
specify all configuration parameters for the network.  When the third option is selected, the screen that 
allows changes to be made to the network will appear immediately as shown below. 
 

   
 
 
For a more detailed description of the UniNET Network, please refer to Tech Note #36. 
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Color UniOP Panels 

 
It is now possible to display any combination of up to 16 different colors on certain models of UniOP 
panels.  To access the color option within the software, the user can select Color palette from the 
Edit menu, or click on the appropriate icon in the Extra ToolBelt.  Doing so will bring up the dialog 
box that is shown below. 
 

 
 

This dialog box allows the user to change the background color and the foreground color (either static 
text or data fields).  The user can select whether to change these colors on a global level or on a 
current selection.  If the user wishes to make the colors the default setting for all subsequently created 
pages, selecting the colors and clicking on the Pick text color button will accomplish this.  Likewise, if 
the user wishes to change the colors only for the currently selected area, this can be accomplished by 
selecting the colors and clicking on the Change button. 
 
The area below the palette bars and above the buttons will indicate the global setting for the project 
file.  For example, in the dialog box shown above, the colors are set for a white background and a 
black foreground.  Every page that is created will have these colors as a default setting unless the user 
specifies otherwise by selecting different colors and clicking on the Pick text color button. 
 
NOTE:  The button entitled Pick text color will change to Pick field color whenever a data field is 
selected.  Likewise, the area below the palette bars that shows the global setting will also change from 
Text color to Field color whenever a data field is selected. 

Changing the Background / Foreground Color Globally 

1.  Either select Color palette from the Edit menu or click on the appropriate icon in the Extra 
ToolBelt. 
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2.  Select the color(s) to be used and click on the Pick text color button. 

Changing the Background / Foreground Color for a Highlighted Area 

1.  Highlight the area that is to be affected. 
2.  Either select Color palette from the Edit menu or click on the appropriate icon in the Extra 

ToolBelt. 
3.  Select the color(s) to be used and click on the Change button. 

Making the Colors of a Data Field or Static Text the Global Default Colors 

1.  Position the cursor somewhere on the data field or on the static text. 
2.  Either select Color palette from the Edit menu or click on the appropriate icon in the Extra 

ToolBelt. 
3.  Click on the Pick text color button. 

Finding Out the Colors of a Particular Area or Field 

1.  Either select Color palette from the Edit menu or click on the appropriate icon in the Extra 
ToolBelt. 

2.  Position the cursor on the desired location by single clicking the left mouse button. 
3.  Click on the title of the dialog box.  The currently selected colors for the area will be reflected in 

the color palette bars. 

Application Notes 

1.  Each field can be in only one color.  For example, assume the user has a field that displays a two 
digit number.  If the first digit is blue, the second digit can not be displayed in any other color but 
blue. 

 
2.  If the user tries to make the background color and the foreground color the same, the software will 

display a text message asking the user if this is what they wish to do.  If the background color and 
the foreground color are the same, everything will appear transparent and no data fields or static 
text will be visible. 

Closing Remarks 

The Designer for Windows is capable of doing all the MS Windows features, for example cutting and 
pasting on the display and copying pages or parts of pages to other pages, copying to the Clipboard, or 
even working on more than one Windows based programs at a time.  The possibilities are amazing.  
We are always adding new drivers for the developing market.  We well continue to develop new 
features to the Designer and the UniOP to aid you in filling that specific application for a Man 
Machine Interface. 


